Chapter 2. Installation

Table of Contents

Installation overview
Install MySQL/Ruby (or Ruby/MySQL)
Install Ruby-DBI
Install Lafcadio
... with RubyGems
... without RubyGems
Test Lafcadio (optional)

Installation overview

Because Lafcadio depends on Ruby-DBI, and Ruby-DBI depends on MySQL/Ruby, an installation of Lafcadio requires at least three separate steps: Installing MySQL/Ruby, installing Ruby-DBI, and installing Lafcadio. You may already have installed the first two parts installed, but in case you haven't I've included install instructions here.